背驰选股公式

股票 2012-02-26 23:47

{上市天数:=BARSCOUNT(CLOSE);
XG:1=1
AND 上市天数>70;}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
_MACD:=(DIF-DEA)*2;

右下开始天数:=BARSLAST((DIF-DEA)*2<=0 AND REF((DIF-DEA)*2,1)>0);
右上结束天数:=右下开始天数+1;
右上开始天数:=BARSLAST((DIF-DEA)*2>0 AND REF((DIF-DEA)*2,1)<=0);

中下结束天数:=右上开始天数+1;
中下开始天数:=REF(右下开始天数,中下结束天数)+中下结束天数;

中上结束天数:=中下开始天数+1;
中上开始天数:=REF(右上开始天数,中下开始天数)+中下开始天数;

左下结束天数:=中上开始天数+1;
左下开始天数:=REF(中下开始天数,中下开始天数)+中下开始天数;

左上结束天数:=左下开始天数+1;

右MACD面积:=SUM(_MACD,右下开始天数+1);
中MACD面积:=REF(右MACD面积,中下结束天数);
左MACD面积:=REF(右MACD面积,左下结束天数);

右DIF_LOW:=LLV(DIF,右下开始天数+1);
中DIF_LOW:=REF(右DIF_LOW,中下结束天数);
左DIF_LOW:=REF(右DIF_LOW,左下结束天数);

右DEA_LOW:=LLV(DEA,右下开始天数+1);
中DEA_LOW:=REF(右DEA_LOW,中下结束天数);
左DEA_LOW:=REF(右DEA_LOW,左下结束天数);


右PRICE_LOW:= IF(右下开始天数=0,LOW,LLV(LOW,右下开始天数));
中PRICE_LOW:= REF(右PRICE_LOW,中下结束天数);
左PRICE_LOW:=REF(右PRICE_LOW,左下结束天数);

右MACD高度_LOW:=LLV(_MACD,右下开始天数+1);
中MACD高度_LOW:=REF(右MACD高度_LOW,中下结束天数);
左MACD高度_LOW:=REF(右MACD高度_LOW,左下结束天数);

XG_TEMP:1=1
AND _MACD<0
AND _MACD>REF(_MACD,1)
AND  中MACD面积<右MACD面积
AND  中MACD高度_LOW<右MACD高度_LOW
AND  中PRICE_LOW>右PRICE_LOW
AND  中DEA_LOW<右DEA_LOW
AND  中DIF_LOW<右DIF_LOW
{XG:HHV(XG_TEMP,3);};


Leave a Reply